Everstream - Enterprise IT - Users may be unable to access various Microsoft 365 apps and services – Incident details

Experiencing partially degraded performance

Users may be unable to access various Microsoft 365 apps and services

Resolved
Partial outage
Started over 1 year agoLasted about 9 hours

Affected

Microsoft Office 365

Partial outage from 7:15 AM to 4:09 PM

Updates
  • Resolved
    Resolved

    After an extended period of monitoring, in addition to internal validations and customer confirmations, we have declared the incident resolved. We understand the impact this incident has had on our users and greatly appreciate your organization's patience and feedback while we worked to resolve this high priority issue in its entirety.

  • Monitoring
    Monitoring

    We've completed applying our mitigation actions and our telemetry is now indicating all previously impacted Microsoft 365 apps or services are operating normally. We're now entering a period of monitoring to ensure all previously impacted apps, services, and scenarios have fully recovered.

  • Identified
    Identified

    We're continuing to apply mitigation actions to provide relief from the residual impact affecting the remaining impacted Microsoft 365 apps and services. Our telemetry is indicating that the remaining impacted scenarios are progressing towards a full recovery and we're closely monitoring to ensure this progress continues.

  • Investigating
    Investigating

    Microsoft Teams:

    Users may be unable to leverage Microsoft Teams functions including presence, group chats, and user registration.