Everstream - Enterprise IT - Public DNS - Degraded State – Incident details

Experiencing partially degraded performance

Public DNS - Degraded State

Resolved
Degraded performance
Started about 2 years agoLasted about 13 hours

Affected

Public DNS Servers

Degraded performance from 4:16 AM to 5:28 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    The Everstream Public DNS servers are currently operating in a degraded state, the IT team is currently working to resolve the issue. Please check this status page for the latest updates.